Starting all over again... again...

When I got my first refurbished LC-A I mentioned that with each new (to me) camera I get, I feel like I'm on a new learning curve trying to figure out its mechanics and then learn how to use it to get the results that I want... 
I also mentioned that I thought my LC-A had a steep learning curve as the results weren't exactly as I was expecting. However, now that Lomography have sent me a replacement and I've succesfully tested it, I'm now wondering if that original camera did have a steep curve, or if it was just malfunctioning. Looking through the photos they don't seem that consistant and more were underexposed due to the faulty shutter than I first thought...
So, I'm starting all over again... again with a refurbished LC-A.
 Here are some results from my first test roll.

Photo03_0Photo06_3Photo05_2 Photo09_6Photo12_9Photo07_4Photo13_10 Photo20_17Photo08_5Photo21_18
The major problem with comparing these photos with the photos I took from my first LC-A is the sunshine... we've had a lot of it lately and the other photos I took were all in winter.

Obviously, like all film cameras, this LC-A loves the light but these photos seem crisper to me with a lovely contrast and colour balance but it will be interesting to see the results with this replacement LC-A in the winter for a better comparison.

It's silly how much better I feel having a working LC-A again, although I didn't have my last one for that long, it definitely made an impression on me and I can't wait to use this replacement more, especially if this weather continues.

Camera: Replacement Refurbished LC-A (from 1991 this time)
Film: Kodak ISO 200
Location: Leeds